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Lesson 2 - Introduction to QGIS 

1. Objectives 
This lesson will introduce the QGIS software. This lesson will largely be practical, to allow you to get to 

grips with the QGIS interface. We will see how to add, manage and visualise vector and raster datasets, 

and how to compose a map within QGIS. 

• Introduce QGIS and the QGIS interface 

• Save a QGIS project 

• Add and visualise vector data in QGIS, view the attribute table, and change vector symbology 

• Add and visualise raster data in QGIS and change raster symbology 

• Compose a map in QGIS 

2. Software 
The software used in this lesson is the current Long Term Release (LTR) QGIS 3.16.4 Hannover 

3. Data  
The data used in this lesson can be downloaded from Canvas in the zip file Lesson2_Data.zip. within 

this folder are the files:  

Data file Detail Source 
amenities.gpkg 
sudan_railways layer 

Vector line layer of railways in 
Sudan (within amenities 
GeoPackage) 

Open Street Map (03/03/2021) 
http://download.geofabrik.de/africa/s
udan.html  

amenities.gpkg 
sudan_health_facilities 
layer 

Vector point layer of health 
facilities in Sudan (within 
amenities GeoPackage) 

WHO (2019) 
https://data.humdata.org/dataset/he
alth-facilities-in-sub-saharan-africa  
Data has been clipped to include only 
health facilities in Sudan. 

khartoum_waterways.shp   Vector polygon layer with 
water bodies and rivers in 
Khartoum 

Open Street Map (03/03/2021) 
http://download.geofabrik.de/africa/s
udan.html  
Data has been clipped to include only 
the area around Khartoum 

Sudan_admin1.shp Vector polygon layer with the 
administrative boundaries for 
States in Sudan 

GADM v3.6 (2018) 
https://gadm.org/  

worldpop_khartoup_buil
dings.TIF 

Raster layer on the urban and 
rural built-up areas in and 
around Khartoum.  

Worldpop (2020) 
https://wopr.worldpop.org/?SDN/Buil
dings  
Data has been modified for the 
purpose of this tutorial 

 

 

 

http://download.geofabrik.de/africa/sudan.html
http://download.geofabrik.de/africa/sudan.html
https://data.humdata.org/dataset/health-facilities-in-sub-saharan-africa
https://data.humdata.org/dataset/health-facilities-in-sub-saharan-africa
http://download.geofabrik.de/africa/sudan.html
http://download.geofabrik.de/africa/sudan.html
https://gadm.org/
https://wopr.worldpop.org/?SDN/Buildings
https://wopr.worldpop.org/?SDN/Buildings
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4. Personalising the Graphical Interface (toolbars and panels) 
It is possible to add and remove toolbars and panels, depending on which ones you use the most and 

wish to have visible.  

You can add and remove toolbars via the Menu: MENU View ► Panels… or MENU View ► Toolbars… 

or with a right click on the existing toolbars, the same list will appear.  Click on the check boxes to add 

or remove toolbars or panels.  

• Add the Manage Layers toolbar 

 

The Manage Layers toolbar will now appear on the left-hand side of the QGIS interface. This toolbar 

contains tools for adding various different data types, or to create new layers. We will come back to 

this toolbar later.  

• Add the Manage Layers toolbar 

We will also now add the Layer Styling panel.  

o MENU View ► Panels► Layer Styling Panel ► Symbology tab  

The panel will appear on the right-hand side of the GIS interface. It provides a shortcut to layer styling 

functionalities (changing colours, adding labels etc). We will come back to this later on.  

 

5. Saving a QGIS project 
The state of your QGIS session is called a project, and this state can be saved into a QGIS project file. 

This means you can close a project and open it up again to continue from where you left off. Any 
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operations to do with saving, opening, or creating a new project can be found via MENU Project. A 

project file is saved in QGZ format (i.e. a .qgz extension).  

The project file saves a lot of information about the status of the project, including the layers added, 

their properties (e.g. symbology) etc. but it is important to note that the data itself is not saved in the 

project file - only the relative path to the data source.  

This means that it is important not to change the location of the data relative to the location of the 

project file (i.e. to not move the data to different folders once the data has been added to QGIS, as 

QGIS will no longer be able to find it).  

Another example, when sharing a QGIS project with others, you must also share the data which is used 

in the project (keeping the same path logic between the project and the data).  

• Save the QGIS project 

Save the project as a .qgz file in the folder that contains the material for Lesson 2 (MENU Project ► 

Save As…) e.g. (…\Lesson_2\Lesson2.qgz). It is important to save your work regularly!  

 

   

 

6. Adding a folder as a favourite 
In the Browser panel, it is possible to create shortcuts to the folders in which your data is stored. This 

means you can quickly access your data to add them to QGIS.  

To do so, in the Browser panel, navigate to the folder containing the data for this lesson 

(Lesson2_Data). Right click on that folder and select Add as a Favorite from the drop-down menu. 

• Browser panel ► Navigate to the folder containing the data for this lesson► Right click on 

the folder (Lesson2_Data) ► Add as a Favorite 
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This will allow you to find the data more easily in the next steps, as the Favorites appear on top of the 

list of folders. Alternatively, if the QGIS project is in the same folder in which your data is stored, this 

can also easily be found via Browser panel ► Project home 

  

7. Vector data in QGIS 
Vector data is made up of either point, line, or polygon geometry. A vector layer can only be made up 

of one type of geometry (i.e. it is not possible to have points and polygons in the same vector layer). 

Each vector layer is associated with an attribute table. These attributes describe the elements in a 

vector layer.  

There are many different formats in which vector data can be stored. The most well-known is the ESRI 

Shapefile (extension .shp), but others such as .kml and .geojson are also commonly used. All data 

formats compatible with GDAL/OGR are also compatible with QGIS 

(https://gdal.org/drivers/vector/index.html ).  

The new standard format is now the Geopackage (extension .gpkg). This format has the advantage 

that it allows the storage of multiple GIS data (layers) in a single file. Unlike the ESRI Shapefile format, 

a single GeoPackage file can contain various data (both raster and vector), in different coordinate 

reference systems, as well as tables without spatial information and layer style files, amongst other 

advantages. These features allow you to share data easily and avoid file duplication. For more 

information on the GeoPackage: https://www.geopackage.org/  

Adding vector data to QGIS  
There are a number of methods that can be used to add data into QGIS, and many different data types.  

Method 1 – Via the Browser panel 

In the QGIS Browser panel, navigate to the folder containing the data for this lesson. You can also 

directly access the data from the folder added to the Favourites earlier.  

•  Add the file Sudan_admin1.shp.  

There are 3 ways to add data from the Browser panel: Browser panel ► Navigate to the exercise 

files ►  

https://gdal.org/drivers/vector/index.html
https://www.geopackage.org/
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• Right click on the file ► Add Layer to Canvas/Project   

• Double click on the file 

• Drag and drop the file into the Layers panel 

 

Method 2 – Via the Data Source Manager 

The Data Source Manager can be accessed via 2 ways:  

• Via the symbol   which can be found within the toolbars, on the left-hand side of the QGIS 

interface. 

• Via MENU Layer ► Data Source Manager.  There are different tabs depending on the type of 

data you wish to add.  

• To add vector layers, you can also access the Data Source Manager by clicking on the Add 

Vector Layer symbol which can be found in the Manage Layers toolbar (toolbar that we 

added at the beginning of the practical).  

We will use the Data Source Manager to add vector data from a GeoPackage database.  

• Data Source Manager  ► Click on GeoPackage tab  ► Click on New ► Navigate to 

the exercise files ► click on amenities.gpkg ► Open  

The file path is now added to the GeoPackage connections list. In addition, the GeoPackage will also 

appear in the drop-down menu in the Browser panel, allowing an easy access. 
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We can now add any layers from this GeoPackage to QGIS, either from the Browser panel (using the 

same three ways outlined in Method 1), or by connecting to the GeoPackage in the Data Source 

Manager: 

• Connect ► Select the layers sudan_health_facilities and sudan_railways (CTRL + click for a 

multiple selection) ► Add ► Close 

 

The layers are now listed in the Layers panel, and visible in the Map View.  

 

Remember to regularly save the project (MENU Project ► Save) 
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Visualising data layers 
In the Layers panel, is a list of the layers present in the project. The check box shows whether the layer 

is visible or not. The symbols at the beginning of each layer name, indicate which type of vector is 

present (point, line or polygon) and the symbology of the layer.  

 

The order of the layers in the Layers list controls the order in which they are displayed in the Map 

view. The priority of visualization follows a top to bottom rule, which means that the top layer 

overlays the others. You can change the order of the different layers, or visualize various layer 

combinations by ticking and un-ticking layers.   

Currently we can see all the data layers, but what happens if you drag the layer Sudan_admin1 to 

the top of the layer list? Drag it back to the bottom, so that we can see all the data layers.  

To get a complete view of a layer in the Map View, you can right click on the layer name in the 

Layers panel ► Zoom to layer. This focuses the Map View on the largest possible zoom of the layer, 

while still being able to see the entire layer.  

First, in the Map View, zoom in so that you can no longer see the outer boundary of Sudan. Now right 

click on the layer Sudan_admin1 in the Layers panel ► Zoom to layer 

Attribute table 
An important characteristic of vector data is that in addition to their geometry, they have an attribute 

table, that describe the elements in a vector file. Attributes can be used, for example, to symbolise 

elements (e.g. colour and style), create labels, to quickly search for specific elements, or to spatially 

analyse vector data.  

• Open the attribute table of the sudan_health_facilities layer 

To open a vector attribute table, you must first select the layer in the layers list. You will know that a 

layer is selected when it is highlighted (in blue or grey). You can then either 

• Click on the attribute table icon (in the attribute toolbar)   

• Select layer ► Right click ► Open attribute table  

We can see that in total, there are 266 elements (health facilities) in this vector layer. Each element is 

represented by one line in the attribute table (and by one point in the map view). Each column 

(known as a Field) represents a different attribute, e.g. the Field Admin1 gives information in which 

administrative state the health facility is found.  

• Which column gives information on the name of the health facility?  

There should always be field that contains a unique value for each element, so that it is possible to 

identify each element individually. In the layer sudan_health_facilities, this unique column has the 

name fid.  
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Vector symbology 
The term symbology refers to the choice of colour and style of the layer. There is a wide variety of 

options and combinations. In QGIS, different types of symbology are available for vectors, depending 

on their geometry (point, line, polygon). The main ones are the single symbol, categorized, graduated 

and rule based. These will be covered in more detail in a future lesson.  

Point Line Polygon 

 

 

 

 

There are two ways to access the symbology of a layer: 

Method 1: Via the Layer Properties Dialog (2 ways to access) 

o Select layer ► Right click ► Properties ►Symbology tab  

o Double click on layer ► Symbology tab  

The Layer Properties Dialog regroups all the properties of a layer, and not just the symbology. There 

are many different tabs here, for example the Information tab which usefully gives the metadata of 

the layer. More information on these tabs can be found in the QGIS documentation.  

Within the Layer Properties Dialog, it is possible to save the symbology of a layer (colour, line 

thickness, labels etc).  
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Method 2: Via the Layers Styling panel 

The Layer Styling panel provides a shortcut to the layer styling functionalities of the Layer Properties 

Dialog (e.g. Symbology, Labels), allowing for a quick and easy way to directly visualise changes made 

to the style of a layer. It does not, however, provide access to all the other properties of a layer, and 

does not allow you to save the style of a layer.  

We added the Layer Styling panel in Section 4, but the Layer Styling panel is not visible by default. If it 

has since disappeared, open it up again:  

o MENU View ► Panels► Layer Styling Panel ► Symbology tab  
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• Change the symbology of the layer sudan_railways 

Go back and open the Layer Properties Dialog and open the Properties tab for the layer 

sudan_railways. Select the following options: 

• Click on Simple line. Additional options will appear below.  

• Click on the Colour bar ► Select new colour ► OK 

• Increase stroke width (line thickness) to e.g. 1,00  

• Change stroke style to e.g. Dash Dot Line 

• Click on Apply to view the changes, and OK when you have finished making the changes 
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• Change the symbology of the layer sudan_health_facilities 

You will see at the bottom of the Layer Properties Dialog that there are some styles that are already 

prepared. Here, we can see that there is a symbol called topo hospital.  

• Click on the marker topo hospital ► Apply 

 

We can see on the map that all the health facilities are now represented by a red cross, although the 

symbols are quite big.  
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• Decrease the Size of the symbols to 4.2  

• Click on the red circle simple marker and change the Stroke colour to black 

• When you have finished making the changes click on Apply ►OK  

  

Alternatively, for vector points, within the Single Symbol option, is to use SVG symbols. These SVG 

images can be useful when making a map, to represent e.g. airports, restaurants, schools, banks, 

hospitals etc. 

• Click on the red cross simple marker and in the Symbol Layer Type, click on SVG marker. 

• In the bottom right-hand corner, in the SVG images section, look through the icons and choose 

one to represent the health centres (e.g. there are different types of crosses).  

• You can change the size and the colour for this marker.  
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• Change the symbology of the layer Sudan admin1 

This layer contains the level 1 administrative boundaries (States) of Sudan  

• Click on Simple Fill and change fill colour to a colour of your choice 

• Change the stroke colour and stroke width (i.e. the border line) 

• Click Apply ► OK 
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Vector labels 
We will now see how to add labels to a layer.  

• Add labels to the layer Sudan_admin1 

Firstly, open the attribute table of the layer Sudan_admin1 and identify the name of the Field (column) 

which provides the name of the column containing the names of each state in Sudan. 

Open again the Layer Properties Dialog for the layer Sudan_admin1, but select the Labels tab  

• In place of the No Labels option, select Single Labels  

Under Value, click on the dropdown arrow. This provides a list of all the existing different attributes 

(i.e. Field) of the vector layer, as we saw in the attribute table. In the list, select the attribute containing 

the names of each state in Sudan that you have just identified.  

There are many different options for labelling, to format the text and position of the labels. It is also 

possible to add labels only to certain elements, or to create different rules to have different types of 

labels to different elements. We will only look at the buffer now, which can help increase the visibility 

of the labels  

• Go to the Buffer tab, check Draw text buffer and increase the Size to 1.5.  

• Click Apply ► OK 
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In the map view, we can now see the names of all the states in Sudan.  

Save the project (MENU Project ► Save) 
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It is possible to copy and paste the symbology of one layer to another, however both layers must be 

of the same data type (e.g. from a vector point layer to another vector point layer).  

To do so, in the Layers panel, right click on the layer you wish to copy the style from ► Styles ► Copy 

Style ► All Style Categories. It is possible to copy only one part of the layer style (e.g. only the 

symbology, or only the labels). Then right click on the layer you wish to add the style to ► Styles ► 

Paste Style ► All Style Categories 

Copy the style of the Sudan_admin1 layer and try to paste it onto the sudan_railways layer. It doesn’t 

work, why not?  

8. Raster data in QGIS 
Adding raster data to QGIS  

• Add the file worldpop_khartoum_buildings.tif 

The methods introduced for adding vector data to QGIS can mostly also be used to add raster data.  

• The Data Source Manager via the Raster tab  

• Via the Browser panel (double click or drag and drop or right click ► add layer to project) 

This layer contains information on the presence of settlements in Khartoum, both urban and rural. The 

dataset is freely available online (see Section 3: Data) but has been slightly modified for the purpose 

of the lesson.  

Currently we cannot see the layer very well. Zoom into the layer (right click ► Zoom to layer). It is also 

possible that the worldpop_khartoum_buildings layer is now covering the visibility of the 

sudan_health_facilities. If this is the case, change the order of the layers in the Layers panel.  
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Note in the Layers panel, the gridded symbol that is used to represent the raster layer. If you click on 

the little arrow on the left, the symbology of the layer is displayed.  

  

Raster symbology 
We can also access the Layers Properties Dialog in the same way as for the vector files. The options 

for symbolising raster data are different than those for vector data. 

 

• Change the symbology of the layer worldpop_khartoum_buildings 

First, open the Layer Properties Dialog for the worldpop_khartoum_buildings layer, and select the 

following:  

• For the Render type ► Paletted/Unique values ► Classify. As the Color ramp is Random 

colors, this attributes a random colour to each of the classes in the raster layer – here we have 

3 classes (see table).  

This table shows the label that corresponds to each raster value.  

Raster value Label 

0 Rural 

1 Urban 

2 Not Built-up 

 

Instead of random colours, we can also select a specific Colour ramp (click on the down arrow), or we 

can interactively choose a colour for each class. This is what we will do here.  

• To interactively change a colour, double click on the colour square you would like to change. 

This opens the Select Color window.  

• For each of the classes, choose a colour. What colours might be appropriate? Use the table 

with the labels to help understand what each raster value represents.  

• Click on Apply to visualise the changes, without needing to close the Layer Properties Dialog.  

Once you are happy with your choice for the 3 classes, you can also change the Label of the classes to 

correspond to the table above.  
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• Double click on each label name to replace with the label names given in the table above. Click 

on Apply  

When you are happy with the style of the layer, from the Style drop down menu, select Save Style… 

to save the symbology of this layer (i.e., the classes, colours…) as a .qml style file, in the folder where 

the data are stored. This will allow you to use it in other QGIS projects if needed. Name the file 

khartoum_urban.  

 

An example of what the map could look like:  
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In the layers list, if you click on the little arrow to the left of the name of this raster layer, you can now 

see the raster legend.  

 

Remember to regularly save the project (MENU Project ► Save) 

 

9. Composing a map layout 
What makes a good map?  
The aim of a map is to communicate information. Often, maps are created to present information to 

people that do not have a background in GIS. The process of making a map, therefore, is the process 

of arranging the elements of a map in a way that, with very few words, any person can understand 

what the map is about.  

There are certain elements that are necessary when producing a map.  

• Title – with the theme, and can include the location of the map if this is useful  
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• Map body – The most important part of the layout, as it contains the map information. It 

should be as big as possible 

• Legend – this explains all the symbols on the map, i.e. how to understand the data in the map. 

It should be complete, clear and easy to understand 

• Scale-bar – represents the ratio of a distance on the map to the actual distance in the real 

world. It is necessary to understand the area covered by the map, and is especially useful when 

changing the size of the map.  

• North arrow 

• Sources of the data used to make the map, and their date 

Other optional elements can be added to a map, e.g. a graticule, an overview, the projection system, 

the software used, author, logo … etc. Together, these elements help the map reader to interpret the 

information shown on the map.  

Map layout in QGIS  
In QGIS, the Print layout is used to prepare maps for printing or exporting to documents. The Layout 

manager is used to manage your print layouts (you can make more than one). You can access the 

Layout manager via 

• MENU Project ► Layout Manager  

• Or in the Project toolbar ►   
 

Within the Layout manager you can, as the name suggests, manage your layouts. Each layout must 

have a unique name. If you have at least one layout in the project, these buttons will become available. 

These can be very useful, e.g. if you would like to make a second map only slightly different to the first, 

the Duplicate option can be very useful. 

 

Click on Create and on the window that pops up (Create Print Layout), give a useful name to the map 

such as “Health Facilities Khartoum” and click on OK.  
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This launches the Print Layout window.  

The Toolbox on the left-hand side provides options to add elements to the layout e.g. adding a map, 

scalebar etc., or to move about in the map layout or move element in the layout. In the toolbar on the 

top are different options for managing map layouts, zooming in and out, etc. You can also undo and 

redo manipulations (e.g. to go back a step if you make an error).  

The Item Properties will enable you to change the properties of the different elements you add to the 

layout (e.g. for the map itself, the scale bar, legend, etc). Right now, there are no elements yet.  

 

Producing a simple map 
We will use the Print Layout to create a simple map of health facilities in Khartoum.  
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• Add a map in the Print Layout 

To add a map in the Print Layout: 

• Use the Add Map symbol   

Or 

• Add Item ► Add Map  

Then draw a rectangle on the display to load the data layer. Make sure to leave some space for the 
other elements to be added to the layout. By default, all the active layers in the Layer Panel (in the 
main QGIS window) will appear in the Map element.  
 

  

Go back to the main QGIS window and uncheck the layers Sudan_admin1 and sudan_railways. Add 
the shapefile khartoum_waterways.shp to the Layers panel and make sure it is above the 
worldpop_khartoum_buildings layer in the list of layers. Go into the Layer Properties and change the 
colour to blue.  

 
Go back to the Print Layout, select the map element, and click on Update Map Properties icon  (in 
the Item Properties). What do you notice?  
 
To stop the layers in the Print Layout from changing depending on the active layers in the Layers panel 
(main QGIS window), we have to Lock layers.  
 



IdeaMapSudan – Online Pre-Training – Lesson 2: Introduction to QGIS – 16/03/2021 23 
 

 
 

• The Move Item Content icon  enables you to move the map within the box, zoom in and 

out (using CTRL + mouse zoom)  

• The Select / Move item icon  enables you to move and reshape the box, or other items 

in the print composer 

Use these tools to reshape the map in the print composer.  

 

• Add a title to the layout 

To add a title to the layout, use the Add Label option 

• Add Item ► Add Label► Draw a rectangle on the display to load the text box   

By doing this, the area that map title will appear is loaded but not the title itself. For this we need to 

type the desired title in the Map Properties section after we have selected the title Item. Type a title 

e.g. Health facilities in Khartoum 
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For the title, we can change the font size by clicking on the Appearance - Font options and increasing 

the size.  

 

• Add a legend to the layout 

Afterwards, we can add a legend by:  

• Add Item ► Add Legend ► Draw a rectangle on the display to load the legend 

Automatically, all the layers that are present in the QGIS project will appear, whether or not they are 

visible. In the legend, you should only represent the layers that are visibly present in the map.  

In the Items section (upper right corner) click on the on <Legend>. Then below on Item Properties. 

There are different sections within the Item Properties. In the Main Properties it is possible to name 

the legend and choose which map the legend corresponds to (in this case we only have one map). In 

the Legend Items section, we can manage which items are show in the final legend.  

• Uncheck Auto-update, to enable you to manually modify the legend elements. 

• Right click on the title worldpop_khartoum_buildings and click on hidden, so that it does not 

appear  

• Check only show items inside linked map this means that only items in the map itself will be 

shown 

• It is possible to change the order in which the legend items are shown, using the up and down 

arrows. Put the khartoum_waterways layer at the bottom of the legend.  

• By default, the name of the layers will be the same as in the Layers panel, however these are 

rarely suitable for the production of a professional looking map. Double click on the title 

sudan_health_facilities to rename it as something more informative (e.g. Health Facilities). 

When you have finished renaming, click on the back arrow to return to the Legend Items. Do 

the same for the khartoum_waterways layer (e.g. Nile river).  

• Move the legend to a suitable location in the layout. Usually, the legend is found to the right, 

to the left, or under the main map.  
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• Add a scalebar to the layout 

We may add a scale bar by going to the respective option in the Add Item section: 
• Add Item ► Scale Bar ► Draw a rectangle on the display to load the scale bar  

Usually, the Scale Bar is placed under the main map. QGIS tries to determine the best properties for 

the scalebar, however it often needs to be adapted. Change the number of Segments to the right as 3, 

and define a Fixed Width of 10km.  

By default the Style is a Single Box, but other options are available if you wish to have a different style.  
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• Add a north arrow to the layout 

We can similarly add a north arrow to the by going to the respective option in the Add Item section as 

previously: 

• Add Item ► North arrow ► Draw a rectangle on the display to load the north arrow  

There is a default North arrow, but if you wish, you can choose a different north arrow from the SVG 

icons proposed in the Item Properties. By default, a map is orientated with North towards the top. If 

the north orientation of the map is not towards the top, it is necessary to link the orientation of the 

North arrow to the orientation of the map (Item Properties in section Image Rotation ►Sync with 

map). In this case, the map is indeed oriented North towards the top.  

• Add the data sources (and date) 

It is good practice to add the sources of the data used in the map. As with the title, this can be added 

using the Add Label option. 

• Add Item ► Add Label► Draw a rectangle on the display to load the text box   

Here we use multiple data sources, it could look something like this:  

 

You may need to move around the map elements on the layout.  

 

• Export the map as an image 
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When the map is finished, we can export the map as an image by going to MENU Layout ► Export as 

image. Select the path for the file to be saved and click Save on the window that pops up. Do the same 

again but as a PDF MENU Layout ► Export as PDF 

In the files on your computer, navigate to the two files, open both of them and zoom in very far. What 

difference do you notice between the PDF and the image?  

Remember to regularly save the project (MENU Project ► Save) 

 

 

Congratulations, you have reached the end of the introductory 

tutorial on QGIS! 

 

If there is still time left, or if you wish to further develop your introductory skills in QGIS, Section 10 

presents some additional exercises, introducing a number of other useful tools in QGIS.  
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10. Additional Exercises 
Installling plugins 
QGIS works with a system based on Plugins / Extensions. This allows you to easily add extra 

functionalities to the software.  

To open the Plugin window MENU Plugins ► Manage and Install Plugins. Here you can manage, install 

and uninstall plugins.  

• Install the autoSaver plugin 

The autoSaver plugin provides a way to regularly and automatically save your QGIS project. This can 
be very handy if you have a tendency to forget to regularly save your work.  
 
In the Plugins window, type ‘autoSaver’ in the search bar. Click on ‘autoSaver’ to select it. The right 
hand side of the window explains what the plugin does. Click on Install Plugin. Once done, close the 
Plugins window. 
 

 

The plugin can be found in two ways:  

• MENU Plugins ► autoSaver ► autosave current project 

• If the Plugins toolbar is activated, with this icon   

Open the autoSaver plugin and in the window that pops up, select Enable auto saver. Select the Interval 

to how regularly you would like your QGIS project to be saved. You can also choose whether to 

autosave layers in edit mode.  
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Displaying a basemap 
 

• Display a basemap: 1/ Install the QuickMapServices plugin  

(Display a basemap only if you have an internet connection)  
 
Install the QuickMapServices plugin: MENU Plugins ► Manage and Install Plugins  
 
In the Plugins window, type ‘QuickMapServices’ in the search bar. Click on ‘QuickMapServices’ to 
select it and then click on Install Plugin. Once done, close the Plugins window. 
 

 

• Display a basemap: 2/ Add contributed pack to QuickMapService  

Click on MENU Web ► QuickMapServices► Settings  
In the QuickMapServices Settings window, select the More services tab and click on Get contributed 

pack. 
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In the window that pops up (‘Last version of contrib pack was downloaded!’), click OK. Click Save to 

close the QuickMapServices Settings window. 

This provides you with many different types of base map layers for visualisation.  

• Display a basemap: 3/ Add satellite imagery as a basemap  

Add satellite imagery as a basemap (MENU Web ► QuickMapServices ► Google ► Google Satellite). 

Add OpenStreetMap as a basemap (MENU Web ► QuickMapServices ► OSM ► OSM Standard). 

Zoom in and out , and pan to explore the area. Uncheck the layers you do not wish to 

visualise while doing so. Can you find the area in which you live in Khartoum? 

Grouping data layers 

To better organise data layers in the Layers panel, it is possible to create Groups. There are several 

ways to create a group.  

• Click on the Add Group icon in the Layers panel, then add (drag and drop) the layers you 

wish to have in the group 

• Right click in the empty space below the layers list ► Add Group then add (drag and drop) 

the layers you wish to have in the group 

• Select the layers you wish to group, and click Group Selected 
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Uncheck all the data layers except for the two basemaps OSM Standard and Google Satellite, and 

choose one of these methods to group them together. Rename the group with a useful title (e.g. 

Basemaps).  

  

Uncheck the tick box for Basemaps. What happens in the map view?  

This allows you to check or uncheck all the layers in the group in one go. You can also add the condition 

to the group to be mutually exclusive. This means that if one layer in the group is visible, the others 

will automatically not be. In the case of our Basemap group, this is very useful as we cannot visualise 

both basemaps at the same time.  

Right click on the group name and select Mutually Exclusive Group. What happens when you check 

the basemap that is not checked?  

 

Using the Properties Widget in the Browser panel  
In the Browser panel, you can find the Properties Widget can be used to show useful information 

about specific layers, and can be enabled or disabled using the icon  
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Select a file in the Browser panel, e.g. Sudan_admin1.shp and enable the Properties Widget.  

  

A new widget opens up with three tabs: Metadata, Preview, Attributes.  

The Metadata tab, as the name suggest, shows the accessible Metadata for the selected layer in the 

Browser panel e.g. geometry type, coordinate reference system… etc. and also the different fields 

(columns of the attribute table) and the properties of each field  

  

The Preview tab provides a preview, for spatial data, of how the data would look if added to the QGIS 

project. (this does not work for non-spatial data) 

 

The Attributes tab provides a preview of the attribute table for vector data.  
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Additional features of the map layout 
For this exercise, please open the Layout Manager, click on the title of the map layout we created 

earlier, click on Duplicate ► give a different name to the new print layout (e.g. Health Facilities 

Khartoum v2) ► OK 

This will create a new map layout, identical to the one we created earlier, and allows us to make 

changes to the new copy, while keeping a copy of the original map created.  

 

 

Adding a graticule (grid) 
A graticule is a network of lines, or points, designed to be used as a reference to make it easier for 

the reader to orient themselves. 

Now that the new map composer has been created,  
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In the items list, click on the map item (Map 1) ► Item properties ► Scroll down until the section 

Grids and click on the little arrow to open the section ► click on the green cross  to add a grid 

► click on Modify Grid 

  

This opens up the many options to modify the grid properties.  

In the Appearance section.  

By default, the grid will use the Coordinate Reference System (CRS) of the map (in this case 

EPSG:4326, i.e. using Longitude and Latitude), You will learn about projections and coordinate 

reference systems in another lesson. We must specify with which Interval we would like lines to 

appear both on the X axis, and the Y axis (by default in Map Units). See what happens when you use 

different numbers (for example, try the numbers 0.1, 0.2, 0.5). Here, we can use the value of 0.2 for 

both the X and Y axis.  

In the Frame section, under Frame style, instead of No Frame, select Zebra. What changes on the 

map?  
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Scroll down to find more Map Grid Properties. Check the Draw Coordinates box. This will display 

coordinates on the edges surrounding the map.  

• For the Format, select Degree, Minute Aligned (as we are using the CRS EPSG:4326, we are 

using Longitude and Latitude. As mentioned earlier, you will learn more about this in another 

lesson.) 

• For the Right and Top options, change from Show All, to Disabled. This means the 

coordinates will only be displayed on the left and bottom sides of the map.  

• Change the Coordinate Precision to 0 as in this case, it does not provide any additional useful 

information.  
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Click on the blue arrow to return from the Map Grid Properties.  

 

Finally, if necessary, readjust the elements on your map.  
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Adding an overview map  
Another useful tool is the overview. This can also help a map reader to situate themselves.  

First, in the main QGIS window, uncheck all the layers except Sudan_admin1, and in the Layer 

Properties of this layer, remove the labels (Single labels > No labels). Then, back in the print composer, 

add a new map   (draw a smaller rectangle next to the main map). In the item list, this map is called 

Map 2. With the map tool  zoom in or out until you can clearly see the whole of Sudan.  

In the Item Properties, scroll down to the Overviews section and click on the little arrow to open the 

options ► click on the green cross  to add an overview ► in the Map Frame option, click on Map 

1.  

You will see a small pink square appear on the map of Sudan (Map 2), that corresponds to the footprint 

(geographical area) covered by the map of Khartoum (Map 1). It is not very obvious here, but you can 

change the Frame Style (like with changing the symbology of a vector layer) to try to make the area 

stand out further.  
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As the Overview map uses an additional map layer, you can add a second Legend to the layout. For 

this new legend, in the Map Properties select Map 2 (instead of Map 1), uncheck Auto update, and 

check Only show items inside linked map, and rename to something more appropriate. You can 

position this above the first legend. The sources list should also be updated to include this additional 

source. You can also add a smaller title above Map 2, e.g. Location of Khartoum in Sudan.  

If necessary, rearrange the elements on the map, and export the map if you wish.  
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11. Additional information and tutorials 
In this section are multiple links, either providing more information on QGIS, or other existing free 

tutorials on QGIS. Please use this information should you need, but do not feel obliged to go through 

it all !! You can use them for help if you have any areas that you particularly struggle with, or for 

additional practice in your own time.  

 

Links for more information 
From the QGIS user manual: https://docs.qgis.org/testing/en/docs/user_manual/index.html  

QGIS graphical user interface (GUI) 

Browser panel 

Layer properties for vectors 

Layer properties for rasters 

Overview of the print layout 

Plugins 

Project files 

A Gentle introduction to GIS – This gives some introductory theory to GIS  
https://docs.qgis.org/testing/en/docs/gentle_gis_introduction/index.html  

Map production  

 

Other tutorials 
QGIS training manual: https://docs.qgis.org/testing/en/docs/training_manual/index.html   

Creating a basic map 

Using the print layout  

Plugins 

QGIS tutorials and tips: https://www.qgistutorials.com/en/index.html  

QGIS manual for digital cartography in censuses and surveys. This tutorial covers some aspects that 

we covered in Lesson 2, but also covers more advanced data manipulation in QGIS, some of which 

will also be covered in this course. An advantage of this tutorial is that is also exists in Arabic.  

https://www.unfpa.org/resources/qgis-digital-cartography-censuses-and-surveys  

https://docs.qgis.org/testing/en/docs/user_manual/index.html
https://docs.qgis.org/3.16/en/docs/user_manual/introduction/qgis_gui.html
https://docs.qgis.org/3.16/en/docs/user_manual/introduction/browser.html
https://docs.qgis.org/3.16/en/docs/user_manual/working_with_vector/vector_properties.html
https://docs.qgis.org/3.16/en/docs/user_manual/working_with_raster/raster_properties.html
https://docs.qgis.org/3.16/en/docs/user_manual/print_composer/overview_composer.html
https://docs.qgis.org/3.16/en/docs/user_manual/plugins/plugins.html
https://docs.qgis.org/3.16/en/docs/user_manual/introduction/project_files.html
https://docs.qgis.org/testing/en/docs/gentle_gis_introduction/index.html
https://docs.qgis.org/3.16/en/docs/gentle_gis_introduction/map_production.html
https://docs.qgis.org/testing/en/docs/training_manual/index.html
https://docs.qgis.org/testing/en/docs/training_manual/basic_map/index.html
https://docs.qgis.org/testing/en/docs/training_manual/map_composer/index.html
https://docs.qgis.org/testing/en/docs/training_manual/qgis_plugins/index.html
https://www.qgistutorials.com/en/index.html
https://www.unfpa.org/resources/qgis-digital-cartography-censuses-and-surveys
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